FANDOM


This is the talk page for Citadel: Presidium Prophet.
Please limit discussions to topics that go into improving the article.
If you wish to discuss matters not relevant to article upkeep, take it to the blogs, forums,
Discord chat, or discussions module.
Thank you.

Glitch Edit

I just wanted to mention, I've had this glitch a couple of times, both as playing a War Hero with Renegade options, though I don't know if that makes a difference. After I become a Spectre and decide to do all the assignments on the Citadel I can, I go to do this one. I'll have say, 8 Intimidate points? The total the page says you need is six...the Renegade reply is permanently greyed out. Anyone else had the same trouble? I'm going back through it now to see if I don't get it when I have just six Renegade points, but I'm not holding out much hope. Herecomethecalvary 20:10, January 15, 2011 (UTC)

Never happened with me, but I have had a low number than eight and still got the renegade option. I'm not sure what is happening with your game. Lancer1289 20:13, January 15, 2011 (UTC)
I just tried it with both six points and seven points, still nada. It's the first time this has happened, I've played several renegade Shepards before, never had an issue, it's just been these last two...whe you go back to the CSec officer, the options are still blanked out. At first I was thinking it was a graphics card glitch (playing on the PC, btw)...but then I realised I had a Sentinel playthrough since then, no issues. It's done this with a vanguard and an engineer femshep, and like I said, the only correlation is they've been War Heros, but following the Renegade path. Herecomethecalvary 20:35, January 15, 2011 (UTC)
It's me again, and unable to remember my login BUT I still get the 'glitch'. Same issue, new game install, 8 Intimidate points, Renegade reply still blanked. I'm wondering if either a) the 360 version has a lower Intimidate count needed, or b) if there's some stupid pre-requisite for getting the Renegade reply that I'm missing? I've noticed it does it if I attempt to complete the assignment before doing any one of Feros, Noveria, or Therum. So say I've just been running around doing random assignments on the Citadel and in the galaxy, that reply isn't there. The points are there, but the reply isn't. -Herecomethecalvary

Bug Edit

The bug is mentioned on the page, but is there any way around it? really annoying. Maybe some "console" command or staff like this?Faust-RSI (talk) 05:45, July 1, 2013 (UTC)

Been searching everywhere for a "fix" myself. Short answer is no, there is no fix. From what I can tell if you run into that bug all you are missing out on is a bit of XP. You have already received any morality points (depending on your choices with the jellyfish). If you can't load a save from before the bug you could just use the console to give yourself some XP and ignore the extra entry in your journal. For myself I didn't figure it was that big of a deal. Others have stated that all achievements are still possible. DeJuanNOnley (talk) 02:45, July 31, 2013 (UTC)
Well, thanks, though it's not a matter of XP :) Yea, I can't load the previous save. Whatever, as you said, it's that big of a deal, but developers could address this bug as it's well-known.Faust-RSI (talk) 05:10, July 31, 2013 (UTC)

Reward Edit

As I have become unsure how to edit articles here and fix current information in an accepted way, this time I first put it on the talk page.

My walkthrough:

  • Talk first with the officer, then the preacher
  • Pay him his permit – he leaves
  • Talk back to the officer

Expected reward as for info on the article: credits, omni-gel, XP
Obtained reward: medi-gel, XP

In the current article this would be the reward for making the officer, not the hanar leave. -- UserCCCSig -- You talkin' to me? -- cCContributions -- 12:58, July 11, 2018 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.