FANDOM


This is the talk page for Feros: Geth Attack.
Please limit discussions to topics that go into improving the article.
If you wish to discuss matters not relevant to article upkeep, take it to the blogs, forums,
Discord chat, or discussions module.
Thank you.

Doesn't Ledra always have Tornado shotguns? Edit

In somewhere around 15 playthroughs of different classes & level of Shepard, I don't ever remember Ledra failing to have a line of "Tornado" shotguns which are one of the better performing shotguns per whatever rank you have. Anon objected that it's just "a random selection of goods by level" but that's not exactly my experience. Any confirmation one way or other would be appreciated, so that a tip can be included. Cattlesquat (talk) 01:43, May 11, 2013 (UTC)

Verified he DOES always have Tornado in the Mass Effect Official Game Guide. He always has a Tornado IV and then may have higher models based on your level. Cattlesquat (talk) 02:20, May 11, 2013 (UTC)

There is just another exploit at the Zhu's Hope. Before you go to the ExoGenie building, in a barge there is room just in front of Davin Reynolds, with an easy-level terminal. Decrypt it (either manually or with omni-gel) to receive assignment to an Amazon system (Investigate shipments). Save, reload, repeat for 133 XP. Not much, but easy and quick. You may use this glitch before going to ExoGeni Headquarters and then after defeating Thorian. Don't know how it will work after you complete that Amazon mission, but don't wanna try either - can break savegame, especially for export. Slowpoke edit: first, XP from decryping terminal are level-wise. My first character was at lv 59, therefore 133 xp, but I've tried new walkthrough with brand new Shepard and Feros as first destination point (was between lvl 11-15) and reward was significantly less - about 20-30 XP. Second, protean highway (and bugged crate) available only until your depart from Feros. After that point elevator to highway will be inactive. 176.194.7.96 21:23, May 20, 2013 (UTC) Ash

I thought Elevator / Prothean Highway were locked down as soon as you return from fighting the Thorian? (as opposed to when you leave Feros) Cattlesquat (talk) 20:47, June 2, 2013 (UTC)

Deactivated Armature in the ExoGeni Headquarters Edit

I am surprised that no one else has noticed this, but the same armature can be killed twice. If you shoot the armature while it is still deactivated—as in before opening the Malfunctioning Object beside it—then you can fight it and kill it; and, it will still activate for you to fight and kill again once you open the Malfunctioning Object. This results in extra experience. --Emasks (talk) 19:07, April 6, 2015 (UTC)

  • I tried this just now and it didn't work. I didn't get to slay the armature again, but Garrus did make an alarmed comment after I opened the Malfunctioning Object. Plokijuh (talk) 06:37, October 8, 2016 (UTC)

Bugs? Edit

I see no listing of known bugs for this mission but I want to bring one up that I'm encountering right now. I can't land on Feros. I've completed Noveria and rescued Liara (then went around the galaxy doing all the assignments open til this point - say twenty levels worth of playtime) and now that I'm at Feros, there is no option to land. Anyone know a work-around that doesn't involve going back 40 hours (my saving habits leave something to be desired)?

Or redirect me to a relevant forum if needed.

Thanks.

S (Oct 2015) —The preceding unsigned comment was added by 70.112.88.73 (talk · contr).

bugs aren't bugs unless confirmed by at least 3 people including you. site policy. that said, nobody else has encountered what you're claiming in the 7 or so years of the game's existence, including reverted attempts. T̴̴͕̲̞̳̖̼̱͒͛̎͒ͫ̃ͧeͩ̈̽̈҉͓̝̰̼̦̫̤̀͠m̫̪̪̯̻͎̫̅̇̓̇͌̚p̸̙̝̓̓͌ͨ͆ͣͥ̂̕o͒̽͐̽͏̞̬̻͕͔͕͚̰͍͠͞ṙ̢̞͚͈̹̰ͨ̓ͭ̈́̌ạ̢̧̪̹̺̺̣̹̲͂͆̏ͪͨ͒ͭř̹͈͜͠y̷͍̻̜̹̼̾̽̈́e̵̹̼̟̦͚͐̈́͌͘d͉̲̣̻͉̱͗̅ḭ̷̻̆͋̆̓̔͝t̨͍̦̫̗͂̅̍̋̆ͩ͝ộ̫̟̬̳̝̲̾ͫ̒̿ͮ̑̚rͯ̎ͨͭ̄̿̽͛҉̠̫̱̠̘̘̲́ͅ7̩̻ͤͩͨ͝͡8̜̣̙͇̻ͨ͛͛̆͒̆̽̒͐͜͡ ͥ̍̉̃̇ͥ̓ͨ͏̕҉̥̹͓̗̤̠̖̤ (talk) 14:25, October 28, 2015 (UTC)


Thanks for taking the time to respond but you could have said something helpful. Keep your nomenclature issues to the editors, call it a bug or whatever you want. Also thanks for the link I asked for. So all in all, thanks for nothing but an unprovoked snarky tone of superiority. It's not as though I tried to make a change in your page. BTW What's a "reverted attempt" mean, anyway? Actually I popped back in here to mention that after I went back to another save and managed to land, I did the quest and as soon as I left planet it locked again. It looks as though its a survey-able planet that's already been cleared. I have no idea what it means, but the age of the game doesn't render my experience irrelevant. As long as systems can play it people will because it's Mass Effect, it's the Foundation Series (Asimov) of video games. Sorry this got longer than I meant, I just wanted to add information that might be helpful to others in the future even if I don't actually get any myself.

S

Possible Glitch/Bug at ExoGeni HQ Entrance Edit

Upon reaching the ExoGeni HQ Entrance (the point at which you can no longer drive the Mako, and have to face Geth Hoppers), there's a possible bug/glitch point.

On the right side of the entrance, slightly higher than the entrance level, there's a crack through which you can peek in. If you walked up there to peek in (say, you want to snipe whatever Geth left inside), there's a small drop from a concrete slab, and I couldn't get back up that slab. In fact, the three of us got trapped in that small space; we can't go through the crack, and we can't get back to on top of the slab. I had to reload a save. (Luckily, I quicksaved regularly and religiously).

I'm putting this possible bug/glitch here for someone else to confirm.  [ pepoluan talk ] 09:49, May 29, 2017 (UTC)

"unprovoked snarky tone of superiority indeed". I faced the same bug. Atm I am attempting trying other mission but else I cannot land on Feros. I got the landing animation but after that I was all of the sudden standing up in space on the ship. 2 cases of the bug. And yes, I bought the game, it is not some warez since at the time i found you worthy of the money. /hulah

Community content is available under CC-BY-SA unless otherwise noted.